Cartoon Dolls Community  - Doll forums and doll maker discussion boards

Cartoon Dolls Community - Doll forums and doll maker discussion boards (http://www.thedollpalace.com/forum/)
-   Coding (http://www.thedollpalace.com/forum/coding/)
-   -   How do you make your props drag and drop? (http://www.thedollpalace.com/forum/coding/22759-how-do-you-make-your-props-drag-drop.html)

Vanilla_heart16 12-24-2010 08:23 PM

How do you make your props drag and drop?
 
Hey everyone! I've been trying to make a new and simple dollmaker. I've used this link: Doll Maker Code and Drag and Drop Script and I've been trying to make my props drag and drop, but with no success. How do you make your items movable on the screen?

Elanorea 12-24-2010 09:48 PM

This'll sound like a no-brainer, but did you customize the script and disable dragging? If everything else is working (ie, the build area is showing, double-click works, etc), but you can't drag-and-drop, that seems the most probable cause.

If not, then the only possible issue that I can think of at the moment is that you might have Javascript disabled on your browser, but if you are able to use other dollmakers, that doesn't seem likely.

Where are you hosting your dollmaker? I might be able to provide better advice if I could take a look at it.

Vanilla_heart16 12-24-2010 10:54 PM

Yeah it does seem like its a nobrainer, which is why I was getting so frusterated when nothing I was doing was working!
I'm using Mozilla firefox. That should work. I am hosting my dollmaker on Freewebs. Freewebs does have an HTML option. Here is the testing page:
html testout - Lovemellow's Fantasy Dolls

No matter if I double click on the image or try to drag it, it won't budge. I put the class="dragme" with the image.

Elanorea 12-25-2010 01:48 PM

Okay, after spending way too much time digging around in the source code, it appears that the doctype declaration (<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">) is what's causing the dollmaker script not to work. Using a different doctype seems to have no effect, so the only solution I can think of is to remove it entirely. I'm not entirely sure what other effects it may have on your website, but it seems to work fine without.

Vanilla_heart16 12-25-2010 08:18 PM

What do you mean? Does freewebs have this doctype declaration? Or was it the original programming from the Doll Maker Script website?

Should I copy and paste the full script from the Doll Maker Script Website and take it out?

Also, thanks for helping me out with this one. I really appreciate it! :D

also, I don't think the dollmaker script may be the issue. I think it has to do with whatever script I am using to make images be draggable. Do you know where I can find a better script where I can just click on the image and it pops up on the box? I've been hunting for this for a while..

Elanorea 12-26-2010 08:05 AM

If you open up the page in a HTML editor (or view the source code by using CTRL-U on the page), it should be the very first line. It's definitely not a dollmaker script issue, since I use it for my dollmaker and it works fine; it might have something to do with the layout you're using.

I copied the code of your page here for testing purposes, so you can see how it works without the doctype declaration.

I'm afraid I don't know any other dollmaker scripts though.

Vanilla_heart16 12-26-2010 02:41 PM

Thanks so much! Thats great that you were able to make it work!

So should I copy the entire HTML of the page- remove the line- then put it back in? I'm not sure how that may effect freewebs, but I can try!

Elanorea 12-26-2010 02:42 PM

Yeah, I guess you could try that.

Vanilla_heart16 12-26-2010 04:20 PM

Anyway thanks soo much for all of your help!
Since Freewebs was giving me too much beef, I just changed the website host. But thanks to your insight, I know what the problem was! :grin:

Elanorea 12-26-2010 10:44 PM

Glad I could help! :)


All times are GMT -4. The time now is 02:03 PM.

© 2007 The Doll Palace